Everything I am reading seems to indicate that 3.1 has vulnerabilities. I suggest only having 3.2 or 3.3 installed.
OpenOffice Prior to 3.2 Multiple Remote Code Execution Vulnerabilities
OpenOffice is prone to multiple remote code-execution vulnerabilities because of errors in processing certain files.
Remote attackers can exploit these issues by enticing victims into opening maliciously crafted files.
exploits may allow attackers to execute arbitrary code within the
context of the affected application. Failed exploit attempts will
likely result in a denial of service.
Versions prior to OpenOffice 3.2 are vulnerable.